Secure boot impedisce avvio di Linux

Non solo Windows: il forum che permette di discutere sui sistemi operativi alternativi a Windows.

Moderatore: Staff forum IlSoftware.it

usag
Active Software Plus
Active Software Plus
Messaggi: 729
Iscritto il: 14 ago 2006 23:40

Secure boot impedisce avvio di Linux

Messaggio da usag »

Salve,
ho una distribuzione Linux (Linux Lite), su un notebook Asus, perfettamente funzionante.
Il notebook è di 5 anni fa, e di basse prestazioni, di fascia bassa, su cui era installato Win 10, home edition, e che ho dovuto rimuovere, per via dell'inusabilità della macchina.
Ora, da 2 giorni, non so perché, ad ogni avvio, mi dice che Grub ha delle firme invalide, e il sistema operativo quindi non s'avvia; ho scoperto, poi, che è il secure boot che impedisce l'avvio della distribuzione, infatti andando a disabilitarlo, il sistema s'avvia correttamente.
Il problema è che una volta salvate le impostazioni del bios, e uscito, al successivo riavvio siam di nuovo da capo, e ogni volta devo tornare nelle impostazioni del bios e disabilitar il secure boot, oltre al fast boot, che anche lui si riattiva ogni volta.
Non capisco il perché, eppure non sono mai andato nel bios ad aggeggiare.
Vorrei evitare che appunto le impostazioni del bios si rimodifichino a proprio piacimento, anche per una questione di sicurezza.
Avete qualche idea in merito?
Grazie a tutti.
L'importante non è sapere, ma saper fare uso di ciò che si sa.

http://www.sicvo.it

Avatar utente
NicodemoTT
Active Software
Active Software
Messaggi: 277
Iscritto il: 04 giu 2020 11:04

Re: Secure boot impedisce avvio di Linux

Messaggio da NicodemoTT »

Se scrivi il modello esatto del notebook forse ti si può aiutare meglio.

usag
Active Software Plus
Active Software Plus
Messaggi: 729
Iscritto il: 14 ago 2006 23:40

Re: Secure boot impedisce avvio di Linux

Messaggio da usag »

Ah certo, scusa; il modello è un Asus X553MA.
L'importante non è sapere, ma saper fare uso di ciò che si sa.

http://www.sicvo.it

Avatar utente
combul
Advanced Software
Advanced Software
Messaggi: 1024
Iscritto il: 13 lug 2011 22:58

Re: Secure boot impedisce avvio di Linux

Messaggio da combul »

Ciao Usag è molto probabile che si sia scaricata la batteria tampone. Prova a fare caso se riavviando il PC senza connessione internet perdi anche le impostazioni di data e ora.
"Chi non si muove, non può rendersi conto delle proprie catene."
Rosa Luxenburg

usag
Active Software Plus
Active Software Plus
Messaggi: 729
Iscritto il: 14 ago 2006 23:40

Re: Secure boot impedisce avvio di Linux

Messaggio da usag »

Ciao Usag è molto probabile che si sia scaricata la batteria tampone.
Ciao, Combul,
sì, effettivamente le riaggiorna tutte le volte che riavvio, appena si connette a internet.
Può esser quello, allora.

Grazie della dritta :applauso:
L'importante non è sapere, ma saper fare uso di ciò che si sa.

http://www.sicvo.it

Avatar utente
combul
Advanced Software
Advanced Software
Messaggi: 1024
Iscritto il: 13 lug 2011 22:58

Re: Secure boot impedisce avvio di Linux

Messaggio da combul »

Figurati. :approvato:
"Chi non si muove, non può rendersi conto delle proprie catene."
Rosa Luxenburg

usag
Active Software Plus
Active Software Plus
Messaggi: 729
Iscritto il: 14 ago 2006 23:40

Re: Secure boot impedisce avvio di Linux

Messaggio da usag »

Scusate,

aggiorno la situazione; allora, io ho smontato la parte retrostante del notebook, per accedere all'interno, e cercar la batteria tampone, ma o son rincoglionito io oppure c'è qualcosa che non quadra, in quanto sta batteria tampone non c'è, non la trovo.
eppure si dovrebbe veder bene e subito; ho alzato anche la scheda madre, per sicurezza, tante volte l'avessero infilata in qalche anfratto, ma niente.
boh, o che computer è? mai visto una roba simile.
Ho fatto anche una foto dell'interno, solo che non so come caricarla, ma spero d'essermi spiegato.
Qualche idea? tutto da buttare? :collasso:
L'importante non è sapere, ma saper fare uso di ciò che si sa.

http://www.sicvo.it

Avatar utente
NicodemoTT
Active Software
Active Software
Messaggi: 277
Iscritto il: 04 giu 2020 11:04

Re: Secure boot impedisce avvio di Linux

Messaggio da NicodemoTT »

Su Youtube ho cercato e trovato un video dove viene mostrato lo smontaggio della scheda madre del tuo computer e la batteria tampone del CMOS, se non prendo una grande cantonata, dovrebbe essere quella che ho indicata con la freccia rossa

Immagine


Ad ogni modo se posti le te immagini forse è meglio, a volte i produttori a parità di sigla mettono schede diverse. Usa pure questo sito di condivisione immagini, ti darà in cambio un link che puoi copio-incollare su un post:

https://it.imgbb.com/

usag
Active Software Plus
Active Software Plus
Messaggi: 729
Iscritto il: 14 ago 2006 23:40

Re: Secure boot impedisce avvio di Linux

Messaggio da usag »

Ciao Nico,

grazie del link; ho provveduto a registrarmi e ho caricato le foto del laptop, che ho fatto.


https://ibb.co/hZYN2Yx

https://ibb.co/c2LLM5g
L'importante non è sapere, ma saper fare uso di ciò che si sa.

http://www.sicvo.it

Avatar utente
NicodemoTT
Active Software
Active Software
Messaggi: 277
Iscritto il: 04 giu 2020 11:04

Re: Secure boot impedisce avvio di Linux

Messaggio da NicodemoTT »

usag ha scritto: 20 set 2021 16:17 Ciao Nico,

grazie del link; ho provveduto a registrarmi e ho caricato le foto del laptop, che ho fatto.
Non serviva registrarsi, è possibile caricare i file anche senza registrazione.

La batteria tampone del CMOS si trova dall'altro lato della scheda madre, quella in cui ci sono anche gli slot per la memoria RAM. Devi smontarla e girarla. Questo è il video di cui parlavo e in cui puoi vedere la procedura per lo smontaggio:
https://www.youtube.com/watch?v=cyopSMjrfeA

usag
Active Software Plus
Active Software Plus
Messaggi: 729
Iscritto il: 14 ago 2006 23:40

Re: Secure boot impedisce avvio di Linux

Messaggio da usag »

Sì, ho visto e l'ho smontata e girata, ma sembrerebbe integrata nella scheda madre, è possibile? nel senso, è tutto piatto.

https://ibb.co/8jC2YTc

È quella tonda grigia, ma non so come fare a rimuoverla, è "al pari" della scheda madre stessa, come se fosse disegnata sopra.
L'importante non è sapere, ma saper fare uso di ciò che si sa.

http://www.sicvo.it

Avatar utente
ethan
Advanced Software
Advanced Software
Messaggi: 1420
Iscritto il: 16 lug 2011 17:23
Località: lecce

Re: Secure boot impedisce avvio di Linux

Messaggio da ethan »

dopo la batteria del laptop integrata, adesso passiamo alla batteria della MB integrata
Asus inizia a farmi veramente schifo

usag
Active Software Plus
Active Software Plus
Messaggi: 729
Iscritto il: 14 ago 2006 23:40

Re: Secure boot impedisce avvio di Linux

Messaggio da usag »

Dopo la batteria del laptop integrata, adesso passiamo alla batteria della MB integrata.
Ah, quindi c'avevo visto bene? e allora, niente.

Tra l'altro, dopo aver rimosso win 10, in quanto inutilizzabile, c'avevo messo Linux Lite, che attualmente funziona anche bene, con la piccola particolarità che non rileva alcuna rete wifi, nonostante gl'abbia installato l'apposito driver; dunque, sono costretto a collegarlo via cavo ethernet.
Asus inizia a farmi veramente schifo.
Anche a me, e da diverso tempo.
L'importante non è sapere, ma saper fare uso di ciò che si sa.

http://www.sicvo.it

Avatar utente
NicodemoTT
Active Software
Active Software
Messaggi: 277
Iscritto il: 04 giu 2020 11:04

Re: Secure boot impedisce avvio di Linux

Messaggio da NicodemoTT »

Eppure vendono le batterie per quel modello:

http://www.genuine-cmos-battery.com/asu ... ttery.html
https://www.jdanielpark.top/index.php?m ... _id=389713

Una truffa o è che siamo fuori strada noi ingannati dalla forma di quel coso tondo-bianco?

Dato che il notebook ce l'hai aperto dovresti dare un'occhiata a quello che fa al minuto 4.10 del filmato:
https://youtu.be/cyopSMjrfeA?t=250

Stacca due piccoli spinotti multipolari, uno dovrebbe essere quello della ventola lì accanto, l'altro? Riesci a vedere a cosa porta?

Avatar utente
Ruoti51
Active Software Plus
Active Software Plus
Messaggi: 525
Iscritto il: 16 dic 2018 16:25
Località: Arezzo

Re: Secure boot impedisce avvio di Linux

Messaggio da Ruoti51 »

ethan ha scritto: 20 set 2021 18:40 dopo la batteria del laptop integrata, adesso passiamo alla batteria della MB integrata
Asus inizia a farmi veramente schifo
Possibile che non ci sia fine al peggio?
Forse sapendo le caratteristiche, con molta manualità e moltissima pazienza, potrebbe essere possibile dissaldarla e metterne un altra che possa funzionare. Mettere nella spazzatura una mb solo perché è finita la batteria mi sembra criminale.
Mai più Asus! :cattivo:
Ogni poesia è misteriosa; nessuno sa interamente ciò che gli è stato concesso di scrivere.
J.L. Borges

Rispondi